Home Resources Forums Nationals Meets Store
04/16/14 01:05 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome to the Chevy Avalanche Fan Club of North America

Become a Supporting Member

Visit the CAFCNA General Store

 
   Home   Help Search Login Register Bookmark  
Advertisement
Put your advertisement image here...


Advertisement
 
Pages: [1] 2  All   Go Down
  Print  
Author Topic: Security light flashes and truck won't start  (Read 6042 times)
0 Members and 1 Guest are viewing this topic.
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« on: 03/10/12 06:25 PM »

OK, first let me say that I did a bunch of searching and found a few things, but nothing that matches my problem exactly. So my son and I are out on the town today and we decide to stop and grab a bite to eat. We were inside for about an hour and a half. We get back to the truck and try to start it. Now, I noticed something was wrong right away because usually I can twist the ignition and let go immediately and it keeps cranking on it's own until it starts. This time I let go and it stopped cranking and didn't start. So I tried again and still nothing. Then I noticed the security light was flashing on the dash and that never happened before. I popped the hood and removed the fuel pump relay and plugged it back in (my mechanic (brother) suggested this). When I went back to try it again, it started right up. Do you think this was just coincidence? There was probably about 5 minutes in between pulling it out and reinstalling before I started again. Definitely not 10 minutes. Ran great all the way home, but I am worried now. I actually had both keys with me and tried both with same results.
No remote start either, and it's a 2004 Avy.

Any ideas or do I have to wait until it happens again?  Help me! 
Logged

You might win the rat race.................but you are still a rat!!!
MS03 2500
CAFCNA 2013 Premium Member
Full Member
*
*
*
*
*
*
*
*
Offline Offline

Posts: 30,758

2500


Awards
« Reply #1 on: 03/10/12 08:55 PM »

This a hard one try disconnenting the battery for about 25 minutes
Logged
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #2 on: 03/10/12 08:57 PM »

Yeah, hard to diagnose when it doesn't happen every time. When I got home I shut the truck off and tried it again. Started right up. I will see what happens in the next few days. Bummer either way because I don't wanna be half way on a trip and then it doesn't start  banghead
Logged

You might win the rat race.................but you are still a rat!!!
MS03 2500
CAFCNA 2013 Premium Member
Full Member
*
*
*
*
*
*
*
*
Offline Offline

Posts: 30,758

2500


Awards
« Reply #3 on: 03/10/12 09:23 PM »

Yeah I'm thinking you have a bad battery
Logged
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #4 on: 03/10/12 09:24 PM »

Yeah I'm thinking you have a bad battery

Really?? Seemed to have plenty of crank power when it wasn't starting. I could have it checked easy enough though, but that was my last thought.
Logged

You might win the rat race.................but you are still a rat!!!
ygmn
Administrator
Full Member
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
Offline Offline

Posts: 31,251


Insert Funny Text Here _______________ .


Awards
« Reply #5 on: 03/11/12 06:02 AM »

you have a 2004 and you turn the key then let go of it and the starter continues to turn over until the engine starts?

Thats your problem right there...as that should not happen with 2004.
Logged

Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #6 on: 03/11/12 07:38 AM »

you have a 2004 and you turn the key then let go of it and the starter continues to turn over until the engine starts?

Thats your problem right there...as that should not happen with 2004.
I have asked my mechanic in the past about this and he told me it was normal. Has done this for 3 years (since I bought it.)
Logged

You might win the rat race.................but you are still a rat!!!
nghtrdr
Full Member
***
Offline Offline

Posts: 134


Avalanche Rules!!


Awards
« Reply #7 on: 03/11/12 08:04 AM »

when i got my Nelson tune i had to do a security relearn.
while doing so the truck will not start but the starter will crank more than normal until the relearn is done..

maybe u need to do a relearn but u will have to perform it at the time that it wont start. im no expert but this is what i have found
its very easy to do
1: Turn ON the ignition, with the engine OFF.

2: Attempt to start the engine, then release the key to ON (vehicle will not start). Observe the SECURITY telltale, after approximately 10 minutes the telltale will turn OFF.

3: Turn OFF the ignition, and wait 5 seconds .

4: Repeat steps 1 through 4, 2 more times for a total of 3 cycles/30 minutes. The vehicle is now ready to relearn the Passlock Sensor Data Code and/or passwords on the next ignition switch transition from OFF to CRANK. IMPORTANT: The vehicle learns the Passlock Sensor Data Code and/or password on the next ignition switch transition from OFF to CRANK. You must turn the ignition OFF before attempting to start the vehicle.

5: Start the engine. The vehicle has now learned the Passlock Sensor Data Code and/or password.
if this does not work u could have a problem with the pass lock sensor. there is a way to bypass it (google) with a simple circuit. or u have a bad corroded connection usually at the bcm, but could be at the ignition switch..

gl
Dan
Logged

04' Summit White, Z71 Loaded WBH Died Dec 27/12 - Black ice and a hydro pole
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #8 on: 03/11/12 08:14 AM »

when i got my Nelson tune i had to do a security relearn.
while doing so the truck will not start but the starter will crank more than normal until the relearn is done..

maybe u need to do a relearn but u will have to perform it at the time that it wont start. im no expert but this is what i have found
its very easy to do
1: Turn ON the ignition, with the engine OFF.

2: Attempt to start the engine, then release the key to ON (vehicle will not start). Observe the SECURITY telltale, after approximately 10 minutes the telltale will turn OFF.

3: Turn OFF the ignition, and wait 5 seconds .

4: Repeat steps 1 through 4, 2 more times for a total of 3 cycles/30 minutes. The vehicle is now ready to relearn the Passlock Sensor Data Code and/or passwords on the next ignition switch transition from OFF to CRANK. IMPORTANT: The vehicle learns the Passlock Sensor Data Code and/or password on the next ignition switch transition from OFF to CRANK. You must turn the ignition OFF before attempting to start the vehicle.

5: Start the engine. The vehicle has now learned the Passlock Sensor Data Code and/or password.
if this does not work u could have a problem with the pass lock sensor. there is a way to bypass it (google) with a simple circuit. or u have a bad corroded connection usually at the bcm, but could be at the ignition switch..

gl
Dan

Thanks Dan, I will give it a try.
Logged

You might win the rat race.................but you are still a rat!!!
ygmn
Administrator
Full Member
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
Offline Offline

Posts: 31,251


Insert Funny Text Here _______________ .


Awards
« Reply #9 on: 03/11/12 12:23 PM »

I have asked my mechanic in the past about this and he told me it was normal. Has done this for 3 years (since I bought it.)
not normal yo umay have bad ignition switch or something.

I heard this only happens on the 2007+ as starting is computer controlled or something..

but with 2004 the key activates ignition switch which activates starter solenoid...

so you should have direct control of starter
Logged

Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #10 on: 03/11/12 12:52 PM »

not normal yo umay have bad ignition switch or something.

I heard this only happens on the 2007+ as starting is computer controlled or something..

but with 2004 the key activates ignition switch which activates starter solenoid...

so you should have direct control of starter
I'll check with my buddy, he has a 2004 Avy also. I'll see if his does it. Please don't think that I am questioning your response, it just confuses me that this is how it has worked since I've owned the truck and the only time it didn't do it is when it wouldn't start.
Logged

You might win the rat race.................but you are still a rat!!!
ygmn
Administrator
Full Member
*
*
*
*
*
*
*
*
*
*
*
*
*
*
*
Offline Offline

Posts: 31,251


Insert Funny Text Here _______________ .


Awards
« Reply #11 on: 03/11/12 01:33 PM »

Did you buy new?

maybe original owner installed some sort of remote starter or something is left behind?
Logged

Thread Killer ... After I post they die?
2002 Pewter Z66 - Sept 2001
CAFCNA Album
LSU BABY!
YANKEES BABY!
SAINTS BABY!
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #12 on: 03/11/12 01:56 PM »

Did you buy new?

maybe original owner installed some sort of remote starter or something is left behind?

Nope, not original owner.

Possible I guess. I wouldn't even know where to start though. I hate dealing with wiring issues, you just never know where it is  banghead
Logged

You might win the rat race.................but you are still a rat!!!
nghtrdr
Full Member
***
Offline Offline

Posts: 134


Avalanche Rules!!


Awards
« Reply #13 on: 03/11/12 05:41 PM »

i have a 04 and mine does not do this. as long as i hold the key is how long it will crank. the only time it would keep cranking is when i did the pcm swap and had to do the relearn. for some reason it will keep cranking after letting go of the key but is fine after the relearn procedure

gl

Dan
Logged

04' Summit White, Z71 Loaded WBH Died Dec 27/12 - Black ice and a hydro pole
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #14 on: 03/11/12 05:48 PM »

i have a 04 and mine does not do this. as long as i hold the key is how long it will crank. the only time it would keep cranking is when i did the pcm swap and had to do the relearn. for some reason it will keep cranking after letting go of the key but is fine after the relearn procedure

gl

Dan

OK, so is there a way to "relearn" without having it fail on me again? It seems to be starting fine now but I don't want to be stranded somewhere later.

BTW, thanks for all the responses from everyone. It's always hard trying to diagnose a wiring problem, or any problem, on the internet.
Logged

You might win the rat race.................but you are still a rat!!!
nghtrdr
Full Member
***
Offline Offline

Posts: 134


Avalanche Rules!!


Awards
« Reply #15 on: 03/12/12 04:36 PM »

a relearn right now wont work.
if it happens again just leave the ignition on for 10 mins and it should be ok.
keep in mind that this is a sign of an impending failure. google "chevy security relearn" and u will find tons of info on the matter. including a simple electrical circuit that might work as a bypass. not sure if it is for passlock II or not

also all this info i have found using google. im no expert on the passlock system

gl

Dan
Logged

04' Summit White, Z71 Loaded WBH Died Dec 27/12 - Black ice and a hydro pole
Trey
Full Member
*****
Offline Offline

Posts: 1,051


Burnin' That Saudi Oil, so you don't have to.


Awards
« Reply #16 on: 03/12/12 04:56 PM »

My 2004 cranks until it starts or until it times out at about 3 seconds.  That's the way it is supposed to work.
Logged

2004 Silver Birch AV 4x4, Leather, CD-Changer, DVD, chrome steps
MODS: TRUXXX Leveling Kit, HIDs, Full-Time Amber DRLs, All-8-on-Hi-Beams Mod, A/C Vent LEDs, Metalcast Engine cover, Headlight and Backup Light Strobes, Sail Panel LEDs, 81-LED Lighted Bowtie, Color-changing LED Headlight Accents, Black Flames, 20" Dub X-Wang Wheels, Power Locking Tailgate, Train Horns, Line of Fire, Smoked Taillights.
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #17 on: 03/12/12 04:58 PM »

a relearn right now wont work.
if it happens again just leave the ignition on for 10 mins and it should be ok.
keep in mind that this is a sign of an impending failure. google "chevy security relearn" and u will find tons of info on the matter. including a simple electrical circuit that might work as a bypass. not sure if it is for passlock II or not

also all this info i have found using google. im no expert on the passlock system

gl

Dan
Well, I spoke too soon. Got home from work today and had some things to do around the house. Went out to start the truck and no go  Beating
Security light was flashing so I left it for ten minutes, but the light never went out like stated above. It went from flashing to a solid light. So I turned the ignition off and tried starting again, but no go again. Then I remembered you said to shut it off and wait 5 seconds. I did that and then it started right up. This is insane. I am gonna have my brother throw the reader on it and see if it has a code but I don't know where to go from here. I can't do the relearn if it keeps starting for me, right?
Logged

You might win the rat race.................but you are still a rat!!!
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #18 on: 03/12/12 05:00 PM »

My 2004 cranks until it starts or until it times out at about 3 seconds.  That's the way it is supposed to work.
Trey, do you have a remote starter or just stock?
Logged

You might win the rat race.................but you are still a rat!!!
nghtrdr
Full Member
***
Offline Offline

Posts: 134


Avalanche Rules!!


Awards
« Reply #19 on: 03/12/12 05:28 PM »

yeah the relearn will only work if the light is on and wont start.
did u check under the dash to see if there are remnants of an old alarm/starter? maybe the previouse owner had an alarm and removed it but left something behind that is now failing (ie bypass module).
check all wires and harnesses for corrosion and broken /grounding connections under the dash at the bcm and ignition switch

u have to start digging into it to see if there is anything obvious

my 04, a friends 05, another friends 03, yet another friends 11,  and a coworkers 08 all stop cranking the sec the key is released. the 04, 05, 08, and 11 all have remote starters,  mine is the only after market one. it would be interesting to know why urs does keep cranking.
i miss sperry he would know


Dan
Logged

04' Summit White, Z71 Loaded WBH Died Dec 27/12 - Black ice and a hydro pole
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #20 on: 03/12/12 05:33 PM »

yeah the relearn will only work if the light is on and wont start.
did u check under the dash to see if there are remnants of an old alarm/starter? maybe the previouse owner had an alarm and removed it but left something behind that is now failing (ie bypass module).
check all wires and harnesses for corrosion and broken /grounding connections under the dash at the bcm and ignition switch

u have to start digging into it to see if there is anything obvious

my 04, a friends 05, another friends 03, yet another friends 11,  and a coworkers 08 all stop cranking the sec the key is released. the 04, 05, 08, and 11 all have remote starters,  mine is the only after market one. it would be interesting to know why urs does keep cranking.
i miss sperry he would know


Dan

Thanks Dan. I'll start looking around a bit and see if anything stands out.


Chris
Logged

You might win the rat race.................but you are still a rat!!!
Trey
Full Member
*****
Offline Offline

Posts: 1,051


Burnin' That Saudi Oil, so you don't have to.


Awards
« Reply #21 on: 03/12/12 06:03 PM »

Trey, do you have a remote starter or just stock?
Mine is just stock.  If I just turn it to start then back to run, it cranks until it starts or until about 3 seconds, whichever comes first.  I learned this when my fuel pump started going bad. It wouldn't start on the first crank, which was always about 3 seconds. Then it would start right up on second crank.
Logged

2004 Silver Birch AV 4x4, Leather, CD-Changer, DVD, chrome steps
MODS: TRUXXX Leveling Kit, HIDs, Full-Time Amber DRLs, All-8-on-Hi-Beams Mod, A/C Vent LEDs, Metalcast Engine cover, Headlight and Backup Light Strobes, Sail Panel LEDs, 81-LED Lighted Bowtie, Color-changing LED Headlight Accents, Black Flames, 20" Dub X-Wang Wheels, Power Locking Tailgate, Train Horns, Line of Fire, Smoked Taillights.
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #22 on: 03/12/12 08:22 PM »

Mine is just stock.  If I just turn it to start then back to run, it cranks until it starts or until about 3 seconds, whichever comes first.  I learned this when my fuel pump started going bad. It wouldn't start on the first crank, which was always about 3 seconds. Then it would start right up on second crank.
It's funny that you mention your fuel pump Trey. That's exactly when I noticed that mine kept cranking after I let go of the key also. Fuel pump went out about a month after I bought it.
Logged

You might win the rat race.................but you are still a rat!!!
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #23 on: 03/13/12 05:55 AM »

Here's an update guys. This morning I went out to start the truck and head off to work. Started fine without any issues, but now my security light is on all the time. Drove just fine though. What does this tell me now???

Also, my buddy brought his 04 Avy into work today and we checked his ignition. His also does the same thing mine does as far as hitting the key and let go, keeps cranking until it starts. He does not have a remote starter and he is second owner with 40K miles on it.
« Last Edit: 03/13/12 10:47 AM by Piranha-z » Logged

You might win the rat race.................but you are still a rat!!!
Piranha-z
Full Member
***
Offline Offline

Posts: 38



Awards
« Reply #24 on: 03/21/12 06:46 AM »

Well, I am baffled on this one. Truck hasn't acted up now for several days. Hard to fix what isn't broke  banghead
Logged

You might win the rat race.................but you are still a rat!!!
Pages: [1] 2  All   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2011, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.121 seconds with 23 queries.
Official SEMA Member ChevyAvalancheFanClub website are the rightful owners as indicated in the ALT TXT tags provided.  Chevrolet, Chevy, Avalanche, PRO-TEC, PASSlock, Midgate, the Chevrolet bowtie logo, Avalanche logo, and their images are registered trademarks of the General Motors Corporation and are used with kind permission as approved by Chevrolet Public Relations, Chevrolet Brand Management, and the Chevrolet Legal Department (thanks Chevrolet!).  OnStar and it's logo are the property of OnStar.  XM, XM Radio, and the XM logo are property of XM Radio.  I'm just a little guy so don't even think about suing me.  It's recommended you read the Privacy Policy and Terms of Use of this website.  The Chevrolet Avalanche Fan Club of North America is a proud member of SEMA, the Specialty Equipment Market Association.  All content appearing on this is protected under international copyright , 2002 to 2008, All Rights Reserved