Home Resources Forums Nationals Meets Store
10/21/14 12:03 AM *
Welcome, Guest. Please login or register.

Login with username, password and session length
News: Welcome to the Chevy Avalanche Fan Club of North America

Become a Supporting Member

Visit the CAFCNA General Store

 
   Home   Help Search Login Register Bookmark  
Advertisement
Put your advertisement image here...


Advertisement
 
Pages: [1] 2  All   Go Down
  Print  
Author Topic: Can't fill up tank in 04 Avalanche  (Read 5090 times)
0 Members and 1 Guest are viewing this topic.
Bigntall1
Full Member
*****
Offline Offline

Posts: 1,888


TRNSFMR


WWW Awards
« on: 07/06/11 06:13 AM »

This has been happening for a while now but just got around to asking what it could be.  I can't fill up my 04 Avalanche.  I can never get more than 26 gallons of fuel in it. After the pump stops I can usually squeeze in another 1.5 gallons but it takes forever when the pump stops every 2 seconds. When I'm done pumping and get it the fuel indicator doesn't reach full.  I don't know if it's my guages or what. Yes I've had problem in the past with my cluster panel.  Gas guage has dropped to empty on a few occassions but it hasn't done it in over a year. 
Logged

http://www.cardomain.com/ride/2195826
White 2004 Avalanche Z66 WBH, Leather Interior, Heated Seats, Side Impact Airbags, Bose Stereo with 6 Disk Changer, XM Radio, Onstar, Automatic Dual Climate Control, Luggage Rack, GM Nerf Bars, AVS Bugshield, AVS Ventvisors, Billet Grille, 22x9.5 VCT-Scarface wheels, 305/40R22 Bridgestone Deuler Tires, Flowmaster Super40 Single-in/Dual-out.
Z66 BUTCH
CAFCNA Cruise Coordinator
Full Member
*
*
*
*
*
*
*
*
*
*
Offline Offline

Posts: 17,783


I love Dachshunds


Awards
« Reply #1 on: 07/06/11 06:18 AM »

Yes, I would think that it is your guage.
Logged



BCmountaineer
CAFCNA 2012 Supporting Member
Full Member
*
Offline Offline

Posts: 410



WWW Awards
« Reply #2 on: 07/08/11 03:22 AM »

I have had an experience with the same sort of symptoms.  If i put the nozzle all the way in, the back pressure(i guess) is telling the pump its full, thats only 20 bucks into the fill up.  My workaround has been to angle it differently only putting the tip of the nozzle in, leaving space for air or fumes or whatnot to escape.
Logged

2004 Avalanche 1500 Z71 WBH: Factory BOSE Sound System, GM Bug/Rain Guards, GM Side steps, Amber DRLs, K&N CAI/FIPK, Dual Electric Fan Conversion...

Region VI - Vancouver, British Columbia
Bigntall1
Full Member
*****
Offline Offline

Posts: 1,888


TRNSFMR


WWW Awards
« Reply #3 on: 07/08/11 04:24 AM »

Yes, I would think that it is your guage.
It's very possible.
I have had an experience with the same sort of symptoms.  If i put the nozzle all the way in, the back pressure(i guess) is telling the pump its full, thats only 20 bucks into the fill up.  My workaround has been to angle it differently only putting the tip of the nozzle in, leaving space for air or fumes or whatnot to escape.
I'll give that a try although mine goes far past $20 before it stops.
Logged

http://www.cardomain.com/ride/2195826
White 2004 Avalanche Z66 WBH, Leather Interior, Heated Seats, Side Impact Airbags, Bose Stereo with 6 Disk Changer, XM Radio, Onstar, Automatic Dual Climate Control, Luggage Rack, GM Nerf Bars, AVS Bugshield, AVS Ventvisors, Billet Grille, 22x9.5 VCT-Scarface wheels, 305/40R22 Bridgestone Deuler Tires, Flowmaster Super40 Single-in/Dual-out.
Scuby
New Member
*
Offline Offline

Posts: 2


Awards
« Reply #4 on: 08/08/11 03:34 AM »

I just recently replaced my fuel pump and the Avi runs and starts nicely.  The problem now is that I can't get fuel in the tank, it shut the station pump down about every .3 of a gallon the line down to the tank is clear. Do any of you have ideas as to what it might be.
Logged
AvManTony
Full Member
***
Offline Offline

Posts: 47



Awards
« Reply #5 on: 08/18/11 05:29 PM »

Sometimes this happens to me to whether my tanks empty or halfway or anywhere in between. I think it has more to do with the actual pump I am using than the truck at all, but maybe I'm outta my mind, wouldnt be the first time I've heard that. Seems like it doesnt happen at certain gas stations.
Logged
AtomicVette
Full Member
***
Offline Offline

Posts: 115


Awards
« Reply #6 on: 08/30/11 09:56 AM »

clogged, obstructed vent tube? does it pump better if you leave the vehicle running?
Logged


2007 Corvette Z51
2008 Avalanche LTZ
2005 Pontiac Vibe GT
Bigntall1
Full Member
*****
Offline Offline

Posts: 1,888


TRNSFMR


WWW Awards
« Reply #7 on: 08/30/11 01:05 PM »

clogged, obstructed vent tube? does it pump better if you leave the vehicle running?

I've never tried pumping gas with the vehicle running.  I guess I'm an old school chicken but I don't want to blow myself up.  dead
Logged

http://www.cardomain.com/ride/2195826
White 2004 Avalanche Z66 WBH, Leather Interior, Heated Seats, Side Impact Airbags, Bose Stereo with 6 Disk Changer, XM Radio, Onstar, Automatic Dual Climate Control, Luggage Rack, GM Nerf Bars, AVS Bugshield, AVS Ventvisors, Billet Grille, 22x9.5 VCT-Scarface wheels, 305/40R22 Bridgestone Deuler Tires, Flowmaster Super40 Single-in/Dual-out.
Wazbro
Full Member
****
Offline Offline

Posts: 970


I love the Chevy Avalanche


Awards
« Reply #8 on: 08/30/11 01:50 PM »

I've never tried pumping gas with the vehicle running.  I guess I'm an old school chicken but I don't want to blow myself up.  dead

I can't blame you for that. Have you tried filling the tank before it got down to 3/4 to find out if it would fill from there? I have heard of some people having trouble filling from less then 1/2 tank.
Logged

2008 AV 6.0L LT3 Autoride Blue Granite Metallic
05snopro440
Full Member
***
Offline Offline

Posts: 297


Awards
« Reply #9 on: 08/31/11 06:09 AM »

Sometimes this happens to me to whether my tanks empty or halfway or anywhere in between. I think it has more to do with the actual pump I am using than the truck at all, but maybe I'm outta my mind, wouldnt be the first time I've heard that. Seems like it doesnt happen at certain gas stations.

Yeah, the station I usually use recently changed their pump handles and now it's a struggle to fill my truck. Never had issues before that though.
Logged

2004 Avalanche Z71 WBH. White w/ charcoal leather, fully loaded including DVD and sunroof. White power bar, 17x8.5" Weld Evo Velocity 6 wheels.
MightyMouse
Full Member
****
Offline Offline

Posts: 607



Awards
« Reply #10 on: 09/09/11 05:08 AM »

I've had this issue from day 1 - 4 years now! It's not all stations though, so I agree that it has more to do with the actual pump. I now know the stations that this will happen at, and if I'm stuck using one of them, I have to hold the trigger myself rather than even setting it on the lowest notch on the handle. Funny thing is that when I do this, it doesn't get enough back pressure, and the damn thing over-fills & spills out all over the truck.  banghead
Logged

'07 Dark Blue Metallic LTZ 4X4, Custom dual exhaust, Injen PowerFlow CAI, Sunroof, Chrome door handles, grill, and mirrors, Ambers, Molded mud flaps, Color-matched GM bug deflector, DiabLEW Predator tune, Billet front & rear bowties, Chrome tailgate handle, Chrome side molding, 22x9.5 Liquid Metal Magma's wrapped in GY Fortera SL 305/40R22 rubber
Scuby
New Member
*
Offline Offline

Posts: 2


Awards
« Reply #11 on: 09/12/11 10:22 PM »

OK still having trouble fueling! I've checked the line going to the tank it's clear.  Checked the vent tube it blows air both directions. Flapper valve in the tank slides and seems to open.  I heard the other day that I needed to check the charcoal filter anyone know anything about this?
Logged
GHP
CAFCNA 2011 Supporting Member
Full Member
*
*
*
*
Offline Offline

Posts: 374


Yo!


Awards
« Reply #12 on: 09/13/11 01:02 AM »

I can never fill up my tank because my credit card always shuts off at $100   banghead
Logged

O7 4WD LT3, Dark Blue Metallic, Amber DRLs, De-badged, GM CAI, Corsa Touring Exhaust, Dual Batteries, Waag Front Runner, 8000 HID, IPCW LED Taillights, Daystar Leveling kit, XD Addicts, Terra Grapplers.


http://grady-y0.mybrute.com
05snopro440
Full Member
***
Offline Offline

Posts: 297


Awards
« Reply #13 on: 10/21/11 12:17 AM »

I'm definitely having issues with mine now. It's been very slow to fill for the last couple months but it's getting worse. This morning when I filled up there was another AV at the next pump and his was slow but much quicker than mine. I'm going to check some things out tonight. Has anyone found a fix for this slow filling problem yet? There was a new F150 at the pump before the av got there and he put in over 100 litres by the time I got to 25 litres.
Logged

2004 Avalanche Z71 WBH. White w/ charcoal leather, fully loaded including DVD and sunroof. White power bar, 17x8.5" Weld Evo Velocity 6 wheels.
Jalon7
New Member
*
Offline Offline

Posts: 7



Awards
« Reply #14 on: 11/01/11 12:52 PM »

   I have an '04 Z66 that will not allow me to pump in more than a trickle without shutting off the pump. I've been guessing something like a clogged vent tube but have not checked it out. Seeing others, especially of the same year, makes me wonder if there might have been a TSB from GM.
   I much prefer to have something to shoot for before I start disassembling my transportation to work. I'm going to look for some more answers and I'll report back to this post if I find anything.
Logged

'04 Avalanche Z66 WBH. No modifications except aux. MP3 input to factory Bose head unit.
05snopro440
Full Member
***
Offline Offline

Posts: 297


Awards
« Reply #15 on: 11/02/11 02:16 AM »

I'm definitely having issues with mine now. It's been very slow to fill for the last couple months but it's getting worse. This morning when I filled up there was another AV at the next pump and his was slow but much quicker than mine. I'm going to check some things out tonight. Has anyone found a fix for this slow filling problem yet? There was a new F150 at the pump before the av got there and he put in over 100 litres by the time I got to 25 litres.

A new gas station opened near me recently, I tried filling up there and I couldn't believe how fast it filled my truck. It did splash back though, so I'll check the vent tube.
Logged

2004 Avalanche Z71 WBH. White w/ charcoal leather, fully loaded including DVD and sunroof. White power bar, 17x8.5" Weld Evo Velocity 6 wheels.
salmonbum
Member
**
Offline Offline

Posts: 20



Awards
« Reply #16 on: 11/09/11 09:43 AM »

Same problem here. 04 Z71. I've had it for a yr and its done it since I've had it. Seems worse in colder weather, but also depends on the pump. I have changed the Evap solenoid and canister this past spring. When I was under there I noticed the rubber hose from filler neck to tank was kinked alittle. Talking to my mechanic buddy he says when someone replaces fuel pump and bolt it back in a bit to the rear it could kink the hose?Huh??/
Logged

"And the first thing you gotta learn if you're gonna be a racecar driver, is that you don't listen to losers like your know-it-all teacher here. Your teacher wants you to go slow, and she's wrong because it's the fastest who get paid and it's the fastest who get laid."
         --Reese Bobby
2004 Avalanche Z71
2003 Duramax Diesel
2003 VW Jetta TDI
2009 Ski Doo XP Gade 800r
2009 Honda CRF 450r
05snopro440
Full Member
***
Offline Offline

Posts: 297


Awards
« Reply #17 on: 11/10/11 06:17 AM »

Same problem here. 04 Z71. I've had it for a yr and its done it since I've had it. Seems worse in colder weather, but also depends on the pump. I have changed the Evap solenoid and canister this past spring. When I was under there I noticed the rubber hose from filler neck to tank was kinked alittle. Talking to my mechanic buddy he says when someone replaces fuel pump and bolt it back in a bit to the rear it could kink the hose?Huh??/

I think it's the new gas pump handles most stations are changing to (vapor recovery?), they seem to make it slow to fill our trucks.
Logged

2004 Avalanche Z71 WBH. White w/ charcoal leather, fully loaded including DVD and sunroof. White power bar, 17x8.5" Weld Evo Velocity 6 wheels.
goatboy
Full Member
***
Offline Offline

Posts: 313


SEE THE USA IN YOUR CHEVROLET TODAY!


Awards
« Reply #18 on: 12/03/11 12:26 AM »

this can't be right ! my 02 & 07 were never any trouble to fill, but this 04 is a pain in my arse  banghead does'nt matter where i take it either, it wont fill well at all, i have to stay right with it and baby it along  banghead
Logged

1st av was a 02 lt z71 in pewter, every option
2nd is a 07 sbom lt3 ,
3rd  av is a black 04 Z71 loaded
4th AV  07 LTZ white 4x4
jimmypsp700
Full Member
***
Offline Offline

Posts: 311


2004 Chevy Avalanche Z71 1500


WWW Awards
« Reply #19 on: 01/05/12 10:05 PM »

My filler neck has always given my problems clicking off the gas pump often but recently has gotten where it wont take gas at anything over a trickle and clicks off every second or two even when pumping very slow.

I called the dealer and they said it could be the fuel filler Solenoid at the gas tank and that it costs about $350 for them to fix.

Question, can i just remove it and do without, what exactly does it do? regulate the amount of fuel allowed to be pumped???

Also my manual says 31 gallon gas tank but i think its more like 26!

thanks,

Jim
Logged

'04 Chevy Av Z71 1500
'90 Chevy Vette L98 TPI
'10 Polaris Sportsman 850XP EPS
'00 Polaris Scrambler 400 2x4
'02 Triton SL8 ATV Trailer
'94 Sierra 32' TT
quest77386
New Member
*
Offline Offline

Posts: 1


Awards
« Reply #20 on: 01/06/12 11:33 AM »

I have a 04 AV. When I fuel up, the pump constantly kicks off. Its seems like fuel is backing up in the tube. It has been going on for the last year and I thought it was the gas stations so I have used several different gas stations and still takes me 20 minutes to fill up. I am glad I am not in a hurry when I fill up my truck. Someone told me try and fill up before it is empty and I have tried that but it still does the same thing. I see that there is several post on this same topic has anyone found a fix to this yet? Help me!
Logged
jimmypsp700
Full Member
***
Offline Offline

Posts: 311


2004 Chevy Avalanche Z71 1500


WWW Awards
« Reply #21 on: 01/06/12 09:25 PM »

2004 Av here too.


I'm going to try to fill it up with the truck running if what i did today doesn't help.

I pulled the cap off the vent line, blew air in it , fed a weed wacker line in as far as it would go  (about 3-4 ft) and sprayed it with carb cleaner.  When i used the pressurized air i could hear it venting afterwards so hopfully that did it but i will find out at my next fill (that's hopfully not 20 minutes...)
Logged

'04 Chevy Av Z71 1500
'90 Chevy Vette L98 TPI
'10 Polaris Sportsman 850XP EPS
'00 Polaris Scrambler 400 2x4
'02 Triton SL8 ATV Trailer
'94 Sierra 32' TT
Bigntall1
Full Member
*****
Offline Offline

Posts: 1,888


TRNSFMR


WWW Awards
« Reply #22 on: 01/14/12 06:42 PM »

Also my manual says 31 gallon gas tank but i think its more like 26!

thanks,

Jim

I'm with you.  I can never get more than 26 gallons. 
Logged

http://www.cardomain.com/ride/2195826
White 2004 Avalanche Z66 WBH, Leather Interior, Heated Seats, Side Impact Airbags, Bose Stereo with 6 Disk Changer, XM Radio, Onstar, Automatic Dual Climate Control, Luggage Rack, GM Nerf Bars, AVS Bugshield, AVS Ventvisors, Billet Grille, 22x9.5 VCT-Scarface wheels, 305/40R22 Bridgestone Deuler Tires, Flowmaster Super40 Single-in/Dual-out.
Troublemaker
CAFCNA Cruise Coordinator
Full Member
*
Offline Offline

Posts: 4,642


NY NY DC PA


Awards
« Reply #23 on: 01/14/12 08:30 PM »

How far down does the gauge show when you fill it to 26 gallons?  I've driven about 50 miles past the "indicator light", and been able to pump 30 gallons in with no problem (other than the cost...)
Logged

Click the pic to listen to along!
River Dude
Full Member
***
Offline Offline

Posts: 85



Awards
« Reply #24 on: 01/14/12 10:44 PM »

On my '04 I had the problem of slow filling & the nozzle clicking off.  The truck was still under warrantee, so I went to the dealer.  I was told topping off the tank completely had contaminated some sort of filter in the vapor recovery system.  They did something(??) and I haven't had the problem since, although when filling I just round off to the nearest nickel once the nozzle kicks off.
Logged
Pages: [1] 2  All   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2011, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.081 seconds with 23 queries.
Official SEMA Member ChevyAvalancheFanClub website are the rightful owners as indicated in the ALT TXT tags provided.  Chevrolet, Chevy, Avalanche, PRO-TEC, PASSlock, Midgate, the Chevrolet bowtie logo, Avalanche logo, and their images are registered trademarks of the General Motors Corporation and are used with kind permission as approved by Chevrolet Public Relations, Chevrolet Brand Management, and the Chevrolet Legal Department (thanks Chevrolet!).  OnStar and it's logo are the property of OnStar.  XM, XM Radio, and the XM logo are property of XM Radio.  I'm just a little guy so don't even think about suing me.  It's recommended you read the Privacy Policy and Terms of Use of this website.  The Chevrolet Avalanche Fan Club of North America is a proud member of SEMA, the Specialty Equipment Market Association.  All content appearing on this is protected under international copyright , 2002 to 2008, All Rights Reserved